Can't disable virtual gamepad

Discussion in 'ePSXe Android Discussion' started by romanr, Jul 10, 2016.

  1. romanr

    romanr New Member

    Messages:
    2
    Likes Received:
    0
    Using ePSXe v.2.0.6 on Android 5.1.1.
    Dualshock 3 is attached via Sixaxis Controller app using android native joystick interface to Player 1 slot. Other joystick slots are disabled (Pad Type PSX: Disconnected, Select Gamepad: none).
    The problem is that the virtual gamepad still works as attached to the Player 1 slot. The phone vibrates together with the joystick and the buttons of the virtual gamepad work.

    Could someone please advice what else should I check to completely disable the virtual/touchscreen gamepad?
    I tried the options "Hide/Show Touch Buttons" -> "Hide buttons", "Pad Skin Landscape" -> "Disable skin" but the virtual touchscreen gamepad still works. Even the buttons are hidden they react on touches.
    Last edited: Jul 10, 2016
  2. NGEmu.com Advertisement

  3. Josh86

    Josh86 New Member

    Messages:
    7
    Likes Received:
    0
    It may or may not be related, but I've always had trouble setting my slot 1 controls to none/disconnected.

    I'm using an Xperia Play (Android 2.3.3) and if I select "none" as the gamepad, and "disconnected" as the "Pad Type Psx", I still see set Player 1 as "virtual" on the startup notification. No matter what I do to set Player 2 as a virtual touchscreen (with pad type) I can't get it to use Player 2 controls. I've never been able to beat Pyscho Mantis in MGS by the traditional port switch method (you can still get past it by dying and then calling Campbell about the statues, though). I don't know if this is only related to the Xperia Play or perhaps Android 2.x.x versions.

    I CAN use player 2 controls when it's set to split screen mode, but it's extremely difficult to use touch screen controls in a space that's only one 1"x1.5". I always just die and use the statue method. Kind of annoying I can't quickly do a port switch option (which I think FPSE has).

    Unrelated, but I've also had a weird android menu bug I noticed on versions 2.0.6 and 2.0.7 (it may go back to versions prior to 1.9 on Android as well, I don't remember) -- I still see the old Android menu that only has the "change disc" option. This button DOES NOT WORK and will not do a disc change. I can only fix the menu in one VERY SPECIFIC situation. I have to have my "game browser mode" set to "browser files". Then after I click "run game" I have to press the "game list" button so it displays the newer game list (not the game details list). When I start a game this way, the menu system will work as intended and I get the full options menu (video, audio, input, change disc, etc) that can be changed while the game is running. If I don't start a game this way, I never get the options menu, just single button that says "change disc" in the android menu during gameplay.

    Coincidentally the method also displays the current player control slot assignments (virtual, none, etc) on running the game. This will not show on game startup if I don't use the above steps.

    Again, these problems come up with games like MGS, where you have to do disc changes. It took me a long time and a lot of trial and error to figure out what the bug was.

    The android port is great -- but the menu system and configuration has a a lot of bugs to this day. The team could take a lesson from FPSE and clean up or rework the entire menu system. Particularly the gamepad editor, it's very clumsy and time consuming (especially the virtual buttons being unresponsive in the editor).

    That said, compatibility and performance with emulation is still as great as it ever was.
    Last edited: Jan 5, 2017

Share This Page