Does Super mario galaxy 2 work now?

Discussion in 'Dolphin Discussion' started by JoonKimDDS, May 4, 2012.

  1. JoonKimDDS

    JoonKimDDS New Member

    Messages:
    230
    Likes Received:
    0
    Last yr, dolphin couldn't run super mario galaxy 2 because
    1. mario was missing eye balls
    2. didn't have background sound.
    3. if you change sound plugin for sound, it lowers FPS to the point it's unplayable.


    Do you guys know if all of these problems have been fixed?
  2. NGEmu.com Advertisement

  3. the_randomizer

    the_randomizer Fluffy Animal Admirer

    Messages:
    3,106
    Likes Received:
    13
    #2, enable LLE Audio (which is dumped from a Wii) and you will get perfect sound, but it is very CPU intensive.
  4. JoonKimDDS

    JoonKimDDS New Member

    Messages:
    230
    Likes Received:
    0
    That's what I wrote as #3. If I enable audio, it lags to the point that it's unplayable. I think sound alone should not cause so much FPS drop and was hoping that it was fixed.
  5. the_randomizer

    the_randomizer Fluffy Animal Admirer

    Messages:
    3,106
    Likes Received:
    13
    Then your computer/laptop likely isn't powerful enough to run it
  6. JoonKimDDS

    JoonKimDDS New Member

    Messages:
    230
    Likes Received:
    0
    if 2500K isn't strong enough, which one do you recommend?
  7. thelittlegumnut

    thelittlegumnut New Member

    Messages:
    433
    Likes Received:
    0
    dolphin works good with dual core. but yer, even on yours i would expect it to run fine... oh well idk then
  8. the_randomizer

    the_randomizer Fluffy Animal Admirer

    Messages:
    3,106
    Likes Received:
    13
    Enable Dual Core and Lock Threads to Core; that should help with speedups.
  9. thelittlegumnut

    thelittlegumnut New Member

    Messages:
    433
    Likes Received:
    0
    though it does cause glitches and freezing on games like NSMB Wii. even if you have dual core or quad... or dual quad...
  10. Tyo

    Tyo New Member

    Messages:
    363
    Likes Received:
    0
    if you get any lag with that, surely you're doing something wrong.

    i played SMG2 on my 2500K (last year), doing fine, even on stock clock, with LLE audio :p

    try release 3.0 if you haven't
  11. the_randomizer

    the_randomizer Fluffy Animal Admirer

    Messages:
    3,106
    Likes Received:
    13
    The 3.0 SVN releases tend to be better overall, especially in the speed department. Though why LLE audio stutters with my Core i7, I have no idea.
  12. Tyo

    Tyo New Member

    Messages:
    363
    Likes Received:
    0
    eah, 3.0 release is till my fav

    probably due to hyperthreading ?
    try disabling HT or lock core option on dolphin

    it's been a long time, but i don't remember any stutter, or maybe not that much that it would make me feel unsatisfied (btw, i set my 2500k at 4.2GHz for daily)

    LLE on thread might also help ? (not sure)
  13. the_randomizer

    the_randomizer Fluffy Animal Admirer

    Messages:
    3,106
    Likes Received:
    13
    3.0 official broke some compatibility, whereas the newer 3.0-SVN variants fixed some of those broken games.
  14. Tyo

    Tyo New Member

    Messages:
    363
    Likes Received:
    0
    i only have several wii game, so 3.0 is enough for me.
    it's been a long time since i last use dolphin.

Share This Page