DPI Awerenes of ePSXe

Discussion in 'ePSXe Compatibility' started by Erzesel, Aug 22, 2015.

  1. Erzesel

    Erzesel Master of Eselhimmel

    Messages:
    413
    Likes Received:
    45
    dear ePSXe-Team.

    Last Time we had more Questions about zoomed and cropped Fullscreen-Graphics-Output.
    http://ngemu.com/posts/2362753/
    http://ngemu.com/posts/2364369/
    In Windowed Mode the Windowssize is zoomed. At higher Windowsizes parts of the Emulationwindow are out of Screen.

    I have employed myself with the matter.
    This should be a bigger problem in the near Future.
    Windows 10 will automatically adjust the DPI correction to the monitor resolution.
    Thus it can happen that are piling up in this regard problems with ever higher resolutions.
    With the good advice the DPI to reduce to 100%, it is no longer done at a 4K monitor or FullHD 17"Notebook, because then Desktopsymbols, Desktopaplications and Fonts are tiny.

    Maybe it is possible to consider this problem in one of your next uptates the ePSXe for Windows and to make the program "DPI-Aware".
    ...Or give Tip how to fix this Problem in other ways...

    This can be also in interest of other Emulatorprogramers!


    With best regards Erzesel
    Last edited: Aug 22, 2015
  2. NGEmu.com Advertisement

  3. DaMan

    DaMan Member

    Messages:
    238
    Likes Received:
    18
    You can do this yourself. Unpack epsxe then put espxe.exe.manifest in ePSXe folder. Or you can use the provided exe with the manifest added to it already if you're lazy.
    Code:
    mt.exe -outputresource:epsxe.exe;#1 -manifest epsxe.exe.manifest
    If you have VS installed and want to merge the manifest yourself.
    Erzesel likes this.
  4. Erzesel

    Erzesel Master of Eselhimmel

    Messages:
    413
    Likes Received:
    45
    Nice.
    It works...
    capture_23082015_213830.jpg

    I think this will made some Users Happy.
    I hope this will be included next time in the official Release.

    Until no official Update available, this one should help.
    To distinguish this modified version of the original, I have inserted the Label "DPI-aware."
    capture_25092015_095718.jpg
    I hope I have no Rights of the ePSXe- authors injured ...:oops:

    For other Users:
    Replace your original ePSXe.exe by this one.
    or follow the recommendation of DaMan. (post #2)
    If someone need another fixed version please ask...

    Virustotal Report: https://www.virustotal.com/de/file/...400b76521dfc03bbff1756a0/analysis/1443170291/

    Attached Files:

    Last edited: Sep 25, 2015
  5. deadalewives

    deadalewives New Member

    Messages:
    3
    Likes Received:
    0
    I just tried using this fix, but now the emulator does nothing but lock up. I have to ctrl+alt+del to close it.
  6. Erzesel

    Erzesel Master of Eselhimmel

    Messages:
    413
    Likes Received:
    45
    I can not reproduce your crash.
    The fixed version has been tested on several different machines without problems.
    There no changes at the programcode it's nothing changed that can crash the Emulator.
    Only the Manifest-file is linked into ePSXe and the Picture is changed...
  7. Niuqorram

    Niuqorram New Member

    Messages:
    4
    Likes Received:
    0
    I get the same problem as deadalewives, except I can't even CTRL+ALT+DEL to exit, I'm forced to restart.
    If I don't use the DPI Awareness exe, it just zooms in to the bottom left, and if I use it, I can't exit the game.
  8. Erzesel

    Erzesel Master of Eselhimmel

    Messages:
    413
    Likes Received:
    45
  9. Anemus

    Anemus New Member

    Messages:
    4
    Likes Received:
    0
    I am trying to do it myself but with no success as upx simply refuses to stay opened. Would you find it in your heart to do the same thing with the newest version of ePSXe ?
  10. generalmx

    generalmx New Member

    Messages:
    4
    Likes Received:
    0
    I looked at these threads and saw no one actually recommended a simple fix that I just confirmed works for me on Windows 10: right-click on ePSXe.exe or its shortcut, go to the Compatibility tab, then select "Disable display scaling on high DPI settings". This will disable Windows's scaling altogether for ePSXe, including in Windowed.

    As for forcing ePSXe DPI-aware I don't think that's really necessary as the DPI scaling for an application not specifically made for it is really very poor--not even Skype looks right, and that's now owned by Microsoft--so I don't recommend it, but there is an alternative way using the Application Compatibility Toolkit.

Share This Page