edgbla's gpuBladeSoft

Discussion in 'PSX Plugin Questions & Troubleshooting' started by KrossX, Jul 21, 2011.

  1. papermanzero

    papermanzero New Member

    Messages:
    61
    Likes Received:
    7
    Same here. I tried to change the config file without success.
    The only reason why I don't use the plugin is missing feature for the higher resolution.

    Edit: Forget the last posts. I have not read the last posts about the internal resolution.
    Last edited: Dec 27, 2015
  2. petran79

    petran79 New Member

    Messages:
    11
    Likes Received:
    0
    Hallo, I have an issue with the GTK library.
    While I placed the libwinthread1.dll in the plugin folder and solved the missing library issue, I get the following messages:
    "The procedure entry point g_mutex_lock could not be located in the dynamic link library C:\Program Files (x86)\gtk-3.8.1\libgdk-3-0.dll"
    "The procedure entry point atk_window_get_type could not be located in the dynamic link library C:\Program Files (x86)\gtk-3.8.1\libgtk-3-0.dll"

    post #232 solution does not work, it gives me same message even after setting path to the portable installer
  3. uVSthem

    uVSthem New Member

    Messages:
    20
    Likes Received:
    0
  4. dukejp

    dukejp Member

    Messages:
    88
    Likes Received:
    4
    Someone have chrashes at the change dis in any game with this plugin? I cant change disc in any multigame disc with this plugin, but other video plugins dont have this problem.
  5. Exos

    Exos New Member

    Messages:
    90
    Likes Received:
    8
    I've completely given up on this plugin. It's goal is supposedly to
    but after all these years it still does not have a basic internal resolution change in it's options..

    For me right now nothing beats Mednafen's libretro fork which comes with a great compatibility and also all these awesome enhancements such as res change, gte accuracy, cpu overclock (which by the way does wonders in many, many games!)

    I'm tired of all of the closed source crap, (both this plugin and the recent disappointment called ePSXe) which does not seem to evolve but rather stall the entire psx emu scene.
  6. emuzoid

    emuzoid New Member

    Messages:
    74
    Likes Received:
    0
    I have Retroarch 1.3.0

    Where are the options for the internal resolution, GTE accuracy and CPU overclock?!
  7. uVSthem

    uVSthem New Member

    Messages:
    20
    Likes Received:
    0
    Does anyone have a link to the correct GTK+ runtime files installer for the gpuBladeSoft plugin GUI? I tried a few different GTK+ runtime installers and none of them seem to get the GUI to run properly.
  8. Exos

    Exos New Member

    Messages:
    90
    Likes Received:
    8
    Download the core through "core updater", then load it with a .cue file. In game press F1 and here you go in "core options". Don't forget you also need the appropriate BIOS files in /system folder.

    From my experience none of the GTK+ runtime installers work correctly. You will probably need to manually add it.
  9. superjupi

    superjupi New Member

    Messages:
    119
    Likes Received:
    17
    Just a heads up that emucr's uploads of the plugin are trojan-laden, as is everything I've attempted to download from them in the past week. The source link is clean, but also has ROMs all over it, so I won't link to it directly, but that's where you'll want to get it from.
  10. emuzoid

    emuzoid New Member

    Messages:
    74
    Likes Received:
    0
    I do this but in the options I don't see the ones you are talking about...
    http://imgur.com/qYp9M4S
  11. Exos

    Exos New Member

    Messages:
    90
    Likes Received:
    8
    I told you to download the core through core updater, you're using an old version..
  12. emuzoid

    emuzoid New Member

    Messages:
    74
    Likes Received:
    0
    That's what I did. I downloaded the PS1 core (Beetke/PSX) with the Core Updater. Its version is 0.9.36.5. RetroArch version is the latest stable, 1.3.0

    Are you using some nightly or something?
  13. Exos

    Exos New Member

    Messages:
    90
    Likes Received:
    8
    No, it should be named "Mednafen PSX" now. Try updating all of the other things or just reinstall Retroarch 1.3.
  14. emuzoid

    emuzoid New Member

    Messages:
    74
    Likes Received:
    0
    It is Mednafen, they also call it Beetle. (It is the only PSX core available anyway)
    http://wiki.libretro.com/index.php?title=Beetle/Mednafen_PSX

    What version does your Retroarch and core say? (After you load it, on the lower left.)
  15. superjupi

    superjupi New Member

    Messages:
    119
    Likes Received:
    17
    Is there anybody else who was perfectly capable of using the config for bladesoft before, but not with this update? First I got:

    "The program can't start because libgdk-3-0.dll is missing from your computer. Try reinstalling the program to fix this problem."

    So, I reinstalled GTK+, still got the same error. Tableflipped, put the dll in System32, got the same error. Put it in SysWOW64, and now a new error:

    "The procedure entry point cairo_device_destroy could not be located in the dynamic link library libcairo-2.dll."

    Why anyone would write a damned text document configurator to require GTK+ in Windows in the first place is beyond me, but now I'm just pissed off from having to troubleshoot this nonsense for the third time.

    Edit: Went back and triple-checked - old configurator still works perfectly fine, but that doesn't get me anywhere. I've tried three different GTK sources, and none of them will make either error go away, but each are still sufficient for the old configurator.
    Last edited: Feb 22, 2016
  16. Exos

    Exos New Member

    Messages:
    90
    Likes Received:
    8
    Here you go: https://i.imgur.com/AzTr1Yh.png

    Save yourself your time and just go with mednafen.. Like I said gte installers did not work for me you need to apply it manually, yeah most of them did not work for me too but I ended up finding one that worked. Don't know where I found it though..
    Last edited: Feb 22, 2016
  17. emuzoid

    emuzoid New Member

    Messages:
    74
    Likes Received:
    0
  18. dukejp

    dukejp Member

    Messages:
    88
    Likes Received:
    4
    i like retroarch, but dont have the option of ┬┐progressive scan? or ┬┐deinterlacing? (i dont know whats the name is), but Bloody Roar 2 in Mednafen look like this:
    [​IMG]

    The white part of the lifebar should be blinking, not with those "white scanlines". GpuBlade does this ok, so the openGL2 and others plugins. If Mednafen psx core get the real and accurate image, i switch to this emulator immediately.
  19. Exos

    Exos New Member

    Messages:
    90
    Likes Received:
    8
    Yeah I believe you are refering to deinterlacing which sadly is not yet supported by RetroArch (but I hope it will be in the future)

    As for the "accurate image" interlacing was present on the original console and that's how the game actually looked like but I think since we were playing with CRTs it wasn't nearly as much visible as it is now.
  20. fischkopf

    fischkopf Member

    Messages:
    199
    Likes Received:
    14
    WTF? I always considered them a trustworthy source... That's a pity because in the past, it has been the best place to get recent builds for various emus. :/

    I didn't even know you could hide a trojan in a dll. What did it try to download?

    edit:
    found a different link it's on some russian website.
    Last edited: Feb 24, 2016

Share This Page