epsxe 1.70 not going full screen properly

Discussion in 'ePSXe Discussion' started by spiderdan, Feb 13, 2010.

  1. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    I'm new to epsxe and I'm having kind of a weird issue. When I play a game, and the emulator goes into full screen mode, windows taskbar does not go away. Also, there is a small gap to the right of the screen where I can see my desktop. I'm able to get rid of the taskbar by enabling auto hide, which is kind of a roundabout way of doing things, but there's still the gap to the right of the screen and one that was covered by the taskbar then becomes apparent at the bottom of the screen. I'm using Windows 7 Ultimate. My graphics card is a gtx 260, so I'm not lacking in power. My graphics plugin file is gpuPeteOpenGL2.dll. I got it from a zip archive I found on Petes site. I used setting for Pete's plugin I found on another forums but I cant seem to find a link now. I'm using dual monitors (only leave on enabled at a time) and manage them with UltraMon, which could possibly be an issue. Any suggestions? Thanks ahead of time!
  2. NGEmu.com Advertisement

  3. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    open the gfx plugin and copy settings to clipboard.
  4. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Thanks for the reply Squall-Leonhart! Here are the settings

    Code:
    Plugin: Pete's OpenGL2 Driver 2.6
    Author: Pete Bernert
    Card vendor: NVIDIA Corporation
    GFX card: GeForce GTX 260/PCI/SSE2
    
    Resolution/Color:
    - 1360x768 Fullscreen - NO desktop changing
    - Internal X resolution: 2
    - Internal Y resolution: 2
    - Keep psx aspect ratio: off
    - No render-to-texture: off
    
    - Filtering: 4
    - Hi-Res textures: 2
    - TexWin pixel shader: on 
    - VRam size: 0 MBytes
    
    Framerate:
    - FPS limitation: on 
    - Frame skipping: off
    - FPS limit: Auto
    
    Compatibility:
    - Offscreen drawing: 1
    - Framebuffer effects: 3
    - Framebuffer uploads: 1
    
    Misc:
    - Scanlines: off
    - Mdec filter: on 
    - Screen filtering: on 
    - Shader effects: 5/4
    - Flicker-fix border size: 0
    - GF4/XP crash fix: off
    - Game fixes: off [00000000]
    
  5. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    its because you set Use Windows Size in Fullscreen mode, to enabled.

    - No render-to-texture: off < also that makes the internal scaling alot slower.
    Last edited: Feb 13, 2010
  6. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Thanks for the continued help Squall-Leonhart! I can't seem to find this Use Windows Size in Fullscreen mode option. Is it under config -> video? I've checked both petes and soft video. Also, I'm curious as to what No render-to-texture is. From what I can find, its something ATI specific. Is that why I should have it off, because I'm using an Nvidia card?
  7. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    you might wanna update to 2.9, iirc, this is a known issue in 2.6 on newer OS.
  8. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Thanks again for the reply squall. I upgraded to 2.9 and have tried with use windows size in full screen mode disabled and enabled and the issue persists. The option to change no render-to-texture now seems to be gone...

    Pete's
    Code:
    Plugin: Pete's OpenGL2 Driver 2.9
    Author: Pete Bernert
    Card vendor: NVIDIA Corporation
    GFX card: GeForce GTX 260/PCI/SSE2
    
    Resolution/Color:
    - 1360x768 Fullscreen - NO desktop changing
    - Internal X resolution: 2
    - Internal Y resolution: 2
    - Keep psx aspect ratio: off
    - No render-to-texture: off
    
    - Filtering: 4
    - Hi-Res textures: 2
    - TexWin pixel shader: on 
    - VRam size: 0 MBytes
    
    Framerate:
    - FPS limitation: on 
    - Frame skipping: off
    - FPS limit: Auto
    
    Compatibility:
    - Offscreen drawing: 1
    - Framebuffer effects: 3
    - Framebuffer uploads: 1
    
    Misc:
    - Scanlines: off
    - Mdec filter: on 
    - Screen filtering: on 
    - Shader effects: 5/4
    - Flicker-fix border size: 0
    - GF4/XP crash fix: off
    - Game fixes: off [00000000]
    
    Config Soft
    Code:
    Plugin: P.E.Op.S. Soft Driver 1.1.18
    Author: Pete Bernert and the P.E.Op.S. team
    
    Resolution/Color:
    - 1360x768 Fullscreen - [32 Bit]
    Stretch mode: 0
    Dither mode: 0
    
    Framerate:
    - FPS limit: on 
    - Frame skipping: off
    - FPS limit: Auto
    
    Misc:
    - Scanlines: disabled
    - Game fixes: off [00000000]
    
  9. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    no render to texture is the Render Mode drop down menu.

    Ok, well if its not the app,then it can only be something external to epsxe. What drivers are you using and do you have any applications installed which might interfere with fullscreen applications?
  10. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Under the render mode I'm seeing pbuffer-texture, pbuffer, copy to texture, and framebuffer. My graphics card drivers are 195.62. The only application I can think of which might cause issues is UltraMon. It does have a "smart taskbar", which I have disabled but perhaps it handles things differently anyway. That could explain the taskbar, but I don't know why the window would not fill my screen. I tried closing UltraMon, but that was no good. I'll see if I can disable it on boot...

    Edit: Tried disabling UltraMon on start and didn't fix the problem. Perhaps just having it installed causes issues (not sure I can give UltraMon up if that be the case). Not sure what the problem is as games go full screen alright. I appreciate all the help Squall!
    Last edited: Feb 14, 2010
  11. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    Framebuffer is setting 2, thats the setting you want to use. apart from that theres nothing in your config which could cause it.

    though you could try launching epsxe with elevated priviledges and seeing if that helps.

    try the latest pcsx-r as well
  12. KrossX

    KrossX クロスエックス

    Messages:
    4,199
    Likes Received:
    27
    I remember having some weird issue like this one, but the culprit was Firefox (nightly builds). It got fixed though.

    Thus, if it worked before, try to check what you installed since then. Or just close any unnecessary running programs and try again.
  13. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Thanks for the replies Squall and KrossX! I tried pcsx-r 1.9.91 and it did the same thing... KrossX, I'm using firefox, but its the most recent stable release. I generally close firefox when running it. This issue has been here since I started using epsxe, which has been recent. Tried running as administrator but no good. I tried to kill any processes that didn't seem necessary, but that didn't help either. Perhaps these processes need to be prevented from running in the first place... Can anyone confirm that epsxe normally works alright on Windows 7 Ultimate 64? Anyway, I took a screenshot to illustrate this. If you look at the top right you can see the window behind epsxe. There is a similar gap at the bottom.

    [​IMG]
  14. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    I can vouch for it. fullscreen switching works fine.

    hmm, is your monitor running at 60hz or 59hz?
  15. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    That's an interesting thought squall... My monitor IS running at 59hz... That being said, I've tried changing it to 60, which it is made to run at and ran at in xp, in windows, Ultramon, and nvidia control panel and they all change back to 59 automatically. Perhaps they could be interfering with each other? Anyway, I also have an lcd tv as my second monitor which I use. It runs at 60hz and is listed at 47.72 KHz (vertical) and 59.799 Hz (horizontal).
  16. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    yeah, go into the nvidia control panel and in the Add/Create resolution pane create a resolution with the refresh rate set to 60.01. The 01 is important.
    I'm not sure if this will fix it, but its fixed fullscreen issues with other apps.
  17. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Thanks for the tip Squall. I was able to get my monitor to stay at 60 hz by adding a custom resolution as you stated. Unfortunately, this did not fix epsxe. On a higher note, unless my eyes deceive me, my monitor seems a tiny bit whitewashed at 59hz compared to 60hz. Is this possible or is it likely my imagination?
  18. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    I haven't seen it myself, but its not impossible.

    What drivers are you currently running??
  19. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Good call Squall! I was using driver version 195.62. When you said that I checked for a new version and found 196.21 had been released last month. Am now using that version and epsxe works great! Note that I did have to restart before the new driver took effect, although NVIDIA control panel listed it. As a side note, I am using my monitor at 59hz at the moment and it still works. Must have changed it back while I was messing around. Plan on going back to 60. Strange, didn't think a company like NVIDIA would be the one to screw this up. Although I did have to do a little trick to get control panel to work with that last release. They must have really dropped the ball. Thanks again for all the help!
  20. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    if you plan on doing any overclocking, 196.21 broke the clock domains so you'll need 196.34
  21. spiderdan

    spiderdan New Member

    Messages:
    11
    Likes Received:
    0
    Thanks for the heads up Squall! The GTX 260 is more than enough power for me, so I don't plan on doing any overclocking any time soon. Out of curiosity, is 196.34 a beta? All I'm seeing is 196.21, but it's listed as WHQL, so I assume there is some sort of untested "cutting edge" version. Not to change topics, but if you don't mind giving some input, are my settings appropriate for my system? I am running the GTX 260 core 216, E7300, and 4gb 800mhz ddr2 ram. Would you agree that Pete's shaders are best? That's about the consensus of what I'm reading, but supposedly there are other good ones.

Share This Page