ePSXe performance issue

Discussion in 'ePSXe Discussion' started by iron666221, Jun 6, 2017.

  1. iron666221

    iron666221 New Member

    Messages:
    2
    Likes Received:
    0
    Hi!

    Im new to this thing so please be patient.

    Aight, so I just recently downloaded ePSXe 2.05 with Pete's OpenGL2 GPU core 2.0.0. and I have run into some issues. Some games run too fast, approx. 400% faster. I use a Win 10 system with an Intel Core i5-4460 3.20 quad-core CPU with an NVIDIA GeForce GTX 960 graphics card. The thing is that neither force frame limitations (to a hard 50/60 frames) nor the emulated frame limitations dont seem to work. Not all games are affected for example Spider-Man runs fine, whilst MediEvil 2 and Rayman 2 do not. Pressing F4 during the emulation does not seem to do anything. The roms I used were in a .cue format if that matters.

    The pic shows one of the configurations I tried.

    Thanks in advance for help!

    Attached Files:

    Last edited: Jun 6, 2017
  2. NGEmu.com Advertisement

  3. FoxSevent

    FoxSevent Not a Registered User

    Messages:
    648
    Likes Received:
    12
    ePSXe - Options - CPU overcloking, set it to x1.
    iron666221 likes this.
  4. iron666221

    iron666221 New Member

    Messages:
    2
    Likes Received:
    0
    Thanks FoxSevent, this sure did the trick!
  5. Bubblenugget

    Bubblenugget New Member

    Messages:
    4
    Likes Received:
    0
    I'm having similar issues after upgrading to ePSXe 2.0.5. Games run at normal speed using the widescreen hack with ePXSe GPU core 2.0.0, but run extremely fast with Pete's OpenGL2 GPU core 2.0.0. The same games run fine with Pete's OpenGL2 driver 2.9 with the widescreen hack off. CPU overclocking is already set to x1.

    Much like Iron noted, setting FPS limits doesn't seem to make a difference for me. Games like Vagrant Story, FF9, Jet Moto, and Wipeout 3 run too fast. Interestingly, I found that some games like FF7 run at normal speed depending on what's going on. For example, the opening cinematic and battles run at normal speed. But any areas with pre-rendered backgrounds run fast.

    These are the settings I'm trying to use.

    Plugin: Pete's OpenGL2 Driver 2.10
    Author: Pete Bernert
    Card vendor: NVIDIA Corporation
    GFX card: GeForce GTX 980 Ti/PCIe/SSE2

    Resolution/Color:
    - 1920x1080 Fullscreen - NO desktop changing
    - Internal X resolution: 2
    - Internal Y resolution: 2
    - Keep psx aspect ratio: off
    - No render-to-texture: off

    - Filtering: 0
    - Hi-Res textures: 0
    - TexWin pixel shader: on
    - VRam size: 512 MBytes

    Framerate:
    - FPS limitation: on
    - Frame skipping: off
    - FPS limit: Auto

    Compatibility:
    - Offscreen drawing: 1
    - Framebuffer effects: 2
    - Framebuffer uploads: 1

    Misc:
    - Scanlines: off
    - Mdec filter: on
    - Screen filtering: on
    - Shader effects: 0/1
    - Flicker-fix border size: 0
    - GF4/XP crash fix: off
    - Game fixes: off [00000000]
  6. dpence

    dpence New Member

    Messages:
    1,612
    Likes Received:
    42
    what other plugins?? epsxe 2.x is very dependent on the SPU over previous versions... video is synced to audio and if you are not using the internal spu, fps can be all over the place...with the internal ogl2 2.0.0 and internal spu It doesn't matter what I set fps too int he plugin, it locks to the correct framerate 60 or 50 fps..If I throw a 3rd party spu or even the peops one in, fps takes an acid trip
  7. Bubblenugget

    Bubblenugget New Member

    Messages:
    4
    Likes Received:
    0
    You nailed it! I'd been using the Eternal SPU plugin with ePSXe for ages. I was even fiddling with the settings in there to see if I could get any improvement. I hadn't even thought to using the core SPU.

    Jet Moto and Vagrant Story are now running at normal speed using the core SPU. Thanks!

Share This Page