Fade to Black PS1 Floor is smoothed but walls are still pixelated when using Pete's Opengl2 2.9

Discussion in 'ePSXe Discussion' started by Knight09able, Feb 13, 2017.

  1. Knight09able

    Knight09able New Member

    Messages:
    10
    Likes Received:
    0
    I'm using epsxe 2.0.5, and Pete's Opengl2 2.9 It appears the floor is smoothed, but the walls are still pixelated, and unchanged. It seems that the floor is 3d, while the walls must be 2d which could be the reason why the pixels aren't smoothed.

    My Settings for Pete's Opengl2 2.9 are here.

    Full screen mode - On
    Desktop Resolution - 1024x768
    Color Depth - 32bit
    Internal X resolution - 2 very high
    Internal Y resolution 3 ultra high
    Stretch mode - 0 Stretch to full window size (standard)
    Render mode - 2 use frame buffer object (fastest mode, if supported)
    Texture Filtering - 6 Extended + smoothed sprites
    Hi Res textures - 0 None (standard)
    gfx card vram - 512
    Off screen drawing - 1 Standard
    Frame buffer effects - 2 Standard
    Frame buffer upload - 2 Full
    Screen Filtering - On
    Shader Effects _ Glslang files (AA shader 4.0 + colors)
    Shader level - More (Walls are still pixelated on any of those settings, even on maximum)
    Scanlines - Off
    Mdec filter - On

    Here are some screenshots

    Fade to Black Picture 3.jpg

    Fade to Black picture 4.jpg

    Is there some sort of extension or extra setting that smooths out 2d in a 3d game? I even used Pete's Opengl2 tweaks which uses xBRZ scaler, but the walls are still the same. They have no more glitches on them when using that extension, but the walls still have pixels.

    There must be a fix for this, or a type of texture filter made just for 2d in a 3d game. Extended + smoothed sprites makes the floors, and polygons smooth, but the walls are still the same, and unchanged.

    Any help is greatly appreciated.

    Thanks.
  2. NGEmu.com Advertisement

  3. acdbrn2000

    acdbrn2000 New Member

    Messages:
    219
    Likes Received:
    27
    You coukd try some of the options under
    High Res Textures to see if any of those help

    Just keep in mind that without texture replacement (which I don't think any PS1 emulator supports) you are using textures designed for far lower resolutions and nothing gets improved by just increasing the internal resolution.
  4. Knight09able

    Knight09able New Member

    Messages:
    10
    Likes Received:
    0
    I tried 2xsal, and stretched, and it makes no difference in the walls.

    Here is the link here that shows pete's opengl2 tweaks extension

    http://ngemu.com/threads/peteopengl2tweak-tweaker-for-peteopengl2-plugin-w-gte-accuracy-hack.160319/

    In the extension There needs to be another deposturize filter option in the ini file that is made for certain ps1 games that have 2d backdrops in a 3d environment that are otherwise not smoothed. Because the plugin only recognizes 3d objects by itself, and not 2d objects.

    This is what the extension should do next

    Before Fade to Black picture 5.jpg

    After
    Fade to Black picture 6.jpg

    If you are wondering why everything else in this screenshot is blurry, is because I simulated this with a photo program. The main purpose is to show you what the walls should look like after. And making the walls more blurry using a low resolution isn't going to make it better. The pixels are still there. The walls just simply need a deposturize filter so there are no more pixels for a higher resolution.
    Last edited: Feb 14, 2017
  5. lagunareturns

    lagunareturns Active Member

    Messages:
    1,525
    Likes Received:
    6
    It is simple, the game renders walls much lower resolution than the floor, no matter what up-scaling it will be pixelated at low resolution source, I mean look at it, it is dealing with pretty large pixels
  6. Knight09able

    Knight09able New Member

    Messages:
    10
    Likes Received:
    0
    Fade to Black picture 15.jpg

    Fade to Black picture 16.jpg

    The walls don't need up scaling. They need a texture filter.
    Last edited: Feb 15, 2017
  7. SimoneT

    SimoneT work haunts me, but I'm running faster!

    Messages:
    222
    Likes Received:
    39
    The walls don't need a texture filter. They need a reprogramming. Here if you run in polygon mode:

    upload_2017-2-16_11-6-10.png
  8. Knight09able

    Knight09able New Member

    Messages:
    10
    Likes Received:
    0
    I noticed the lines on the very bottom left of the wall is better anti-aliased. How do you play the game with better lines on the walls? Did you actually reprogram the walls, or is this just from having it in polygon mode?
  9. Knight09able

    Knight09able New Member

    Messages:
    10
    Likes Received:
    0
    I noticed Fade to Black in the DOS version the walls are in higher resolution.

    Fade to Black dos picture 1.png

    The lines on the bottom of the walls are more jagged on the ps1 version even when you run everything in high resolution.
    Last edited: Feb 16, 2017
  10. dpence

    dpence New Member

    Messages:
    1,569
    Likes Received:
    40
    dude I wouldn't worry about it...it's a flippin PSX game they are all low resolution and any filtering/enhancement is just a bonus.. not all games are gonna look great or even acceptable. it will NEVER look like the PC version cause the PC version, by default, even on the old crappy low resolution PC's, has/had better texture size/resolution over a PSX

Share This Page