Gigaherz's cdvd plugin

Discussion in 'PS2 Plugin Questions & Plugin Troubleshooting' started by GiGaHeRz, Feb 1, 2008.

  1. Jamould

    Jamould New Member

    Messages:
    3
    Likes Received:
    0
    Just wondering how I would use this to extract the titantrons from WWF Smackdown Just bring it I think there in .ipu format
  2. gelopy027

    gelopy027 New Member

    Messages:
    1
    Likes Received:
    0
    i am using plugin 0.7.0 and am playing monster rancher 4. i can't generate a monster from any disk i insert because the emulator freezes after i change disks... anyone got a solution???
  3. naravus

    naravus New Member

    Messages:
    1
    Likes Received:
    0
    Will disc changing ever work T_T, I'm tired of staring at "Please open the disc tray" :<
  4. jaceleon

    jaceleon New Member

    Messages:
    1
    Likes Received:
    0
    Temporary Solution

    I just found that this method works for me by accident. It does work for me 100% of the time, but idk about your cases.

    Let's use this example:

    I use Codebreaker 10 and it always crashes whenever it asks for a CD swap, so I open pcsx2, use P.E.Op.S plugin, then load the CD. it will load. then do your thing over there. now, when it prompts you for a CD change, change the disc, but dont press the X button, instead, press escape, then configure. change the CD plugin to Gigaherz. Then continue the game by pressing execute. then press X (screen is black so you wont see anything, but it is there.....). then press escape. then change the plugin back to P.E.Op.S. then return to the game. the game then commences with all my cheats.

    My guess is that P.E.Op.S never give the game the idea that it already swapped discs. So I use Gigaherz to just give that instruction, then return to the latter said to continue the command left by the Gigaherz plugin.

    I hope it helps.

    I'll try posting the console next time, for a sample.
    Last edited: May 25, 2010
  5. D4nK3sT

    D4nK3sT New Member

    Messages:
    2
    Likes Received:
    0
    I am hoping you can help with this. I am trying to use pcsx2 0.9.7.3113 (I have 0.9.6 and it works fine) when i mount my image using daemon tools and select the drive using the gigaherz .7 and try to run the game get an error coming up telling me cdvd plugin load fail.

    I have tried previous versions of the plugin and it tells me the plugin fails.

    Any help would be appreciated. Thanks

    sys specs
    amd quad core phenom 9950
    4 gigs ddr2 ram
    evga 275 gtx
  6. D4nK3sT

    D4nK3sT New Member

    Messages:
    2
    Likes Received:
    0
    Nvm figured it out had to change from iso to plugin :)
  7. pmunar6

    pmunar6 New Member

    Messages:
    1
    Likes Received:
    0
    Monster Ramcher 4 Disc Swapping WORKS!!

    Step 1: Download the Monster Rancher 4 NTSC ISO

    Step 2: After you download the ISO, download the plugin 0.7wip4(found on this forum) and extract in the plugin folder of PCSX2.

    Step 3: put an audio CD in your drive.(wait till it reads the CD). Then proceed to Step 3.

    Step 3: Open PCSX2, you should get some test results leave it. Go to CDVD option and set plugin make sure the plugin is 0.7wip4 and go to plugin menu and set the drive(VERY IMPORTANT STEP FOR LATER)

    Step 4: Set the CDVD option back to ISO, and browse for your monster rancher 4 ISO.

    Step 5: Now BOOT FROM THE ISO, fast or full doesnt matter

    Step 6: Load your game and go to shrine.
    FINALLY YOUR READY TO MAKE YOUR MONSTER

    Step 7: Go to Saucer Stone, it will ask to put in your CD.

    Step 8: Go to CDVD option again and set it to plugin. A pop-up will appear click "SWAP DISC"

    Step 9: Proceed with the on-screen instructions, once you are prompted to place the monster rancher 4 CD.

    Step 10: Switch the CDVD to ISO.

    Step 11: NOW YOU HAVE YOUR MONSTER
  8. srinivas

    srinivas New Member

    Messages:
    1
    Likes Received:
    0
    illegal disc error

    I downloaded the DVD plugin 0.6 and even o.7. But the emulator gives a illegal disc error and shows screen - insert playstation 2 disc

    * CDVD Test: 1. Opening drive '\\.\E:'... * CDVD Test: ok.
    * CDVD Test: 2. Starting read thread... * CDVD Test: ok.
    * CDVD Test: 3. Checking Sizes...
    * CDVD Test: * Checking Sector Count... * CDVD: IO thread started...
    * CDVD Test: 844905984 sectors.
    * CDVD Test: * Checking Layer Break Address... * CDVD Test: 422452992. Double laye
    * CDVD Test: 4. Attempting to read disc TOC... * CDVD Test: skipped (not a cdrom).
    * CDVD Test: 6. Attempting to detect disc type... * CDVD Disk Open: 2 tracks (1 to
    * * Track 1: Data (Mode 2) (422452993 sectors)
    * * Track 2: Data (Mode 2) (422452991 sectors)
    * CDVD Test: Illegal Disc.
    * CDVD Test: 7. Testing USER sector reading... * CDVD Test: Reading sector 16 in us
    * CDVD Test: Reading sector 17 in user mode...ok.
    * CDVD Test: Reading sector 18 in user mode...ok.
    * CDVD Test: Reading sector 19 in user mode...ok.
    * CDVD Test: Reading sector 20 in user mode...ok.
    * CDVD Test: Reading sector 21 in user mode...ok.
    * CDVD Test: Reading sector 22 in user mode...ok.
    * CDVD Test: Reading sector 23 in user mode...ok.
  9. SomIdiot

    SomIdiot New Member

    Messages:
    1
    Likes Received:
    0
    d'oh!

    I'm having some troubles getting my emu to see a disc at all. Have the latest stable pcsx2 code (.98 compiled April of this year was latest on the site yesterday) and apparently it came bundled with some .8 code for your plugin. I've set it to look at the disc (currently tried GranTourismo 4 and Campions of Norrath) but it only boots to see two mem cards. I've tried updating firmware of the drive and it's still doing the same thing. peops doesn't seem to want to be seen at all as a plugin. I get this line when I start my emu: "CDVD Plugin C: Version 3 != 5"

    when I fire up the emulation I get:
    Opening CDVD
    * CDVD: Opening drive '\\.\D:'...
    * CDVD: IO thread started...
    * CDVD: Disk Type: No Disc

    Also I tried .6 and .7 code and I get
    1. Opening drive '\\.\D:\... ok.
    2. Starting read thread... ok.
    3. Checking Sizes...
    *Checking Sector Count... 2594960 sectors.
    *Checking Layer Break Address... error. Probably not a DVD. Assuming CDROM....
    4 Attempting to read disc TOC... failed!

    any thoughts?

Share This Page