NO$GBA running slow help with FPS

Discussion in 'No$GBA Discussion' started by Locojax, Mar 1, 2009.

Thread Status:
Not open for further replies.
  1. Locojax

    Locojax Gaming Fanitic

    Messages:
    9
    Likes Received:
    0
    my NO$GBA is running slow when i play Pokémon Diamond and Pearl could it be my comp or is the FPS set wrong i dont understand the whole FPS thing so can someone help me??
    Last edited: Mar 1, 2009
  2. NGEmu.com Advertisement

  3. SCHUMI_4EVER

    SCHUMI_4EVER Hackin 'n Slashin Staff Member Award Winner!

    Messages:
    28,624
    Likes Received:
    18
    It's related to the strength of your CPU. If it's too old and not strong enough then there is not really anything you can do to speed no$gba up. You can try setting the renderer to nocash and changing the speed/frameskip settings but that's won't cause a huge improvement, so basically you are stuck with it running as it is.
    You can try DeSmuME, but it requires even more CPU power than no$gba, runs smoother though if you have that CPU power.
  4. Locojax

    Locojax Gaming Fanitic

    Messages:
    9
    Likes Received:
    0
    i see ok well thx for the help
  5. kraken

    kraken New Member

    Messages:
    52
    Likes Received:
    0
    What are your specs? I can run no$GBA full speed on an AMD X2 5200, but not an AMD 3200.

    Also, don't use any addon programs like myzoom as those will eat CPU and make sure everything else that was running is closed. Try disabling sound and gamepads as well.
  6. Zaertix

    Zaertix New Member

    Messages:
    28
    Likes Received:
    0
    Try this:

    [​IMG]

    Those are what I use, and mine runs perfectly. If it lags at all, I would assume it's because your computer is old, and can't handle it.
    Last edited: Mar 1, 2009
  7. Dax

    Dax ライチュウ|タオ

    Messages:
    4,016
    Likes Received:
    20
    You can also try DeSmuME, as it is catching up quite quickly to No$GBA.
  8. SCHUMI_4EVER

    SCHUMI_4EVER Hackin 'n Slashin Staff Member Award Winner!

    Messages:
    28,624
    Likes Received:
    18
    The nocash renderer is faster than the OpenGL one Zaertix
  9. Zaertix

    Zaertix New Member

    Messages:
    28
    Likes Received:
    0
    Yeah I know this. But when I start certain games, (the picking of the pokeballs in Pearl and Diamond, and even Phineas and Ferb) the 3D textures are skewed. And switching it to opengl made them clear :D
  10. Locojax

    Locojax Gaming Fanitic

    Messages:
    9
    Likes Received:
    0
    well im gonna try what Zaeritx said and see if it works im running NO$GBA on a crappy computer cuz the one i have i dont want to put to much stuff on it

    im not running any addons and everything is closed, i dont disable the sound cause sometimes for reasons unknown it will freeze god knows y and i dont have any gamepads on just my keyboard
    Last edited: Mar 2, 2009
  11. SCHUMI_4EVER

    SCHUMI_4EVER Hackin 'n Slashin Staff Member Award Winner!

    Messages:
    28,624
    Likes Received:
    18
    It "freezes" because when you set sound to 'none' then sound emulation also does not play and some games for instance like Pokemon wait for the death cry of the pokemon at the end of the battle, but because sound emulation never plays it just sits there waiting forever and appears frozen.

    If you had checked the FAQ you would know that.
  12. Locojax

    Locojax Gaming Fanitic

    Messages:
    9
    Likes Received:
    0
    i see well thx for the info
    and for the not i didnt check the FAQ cuz im a noob and noobs dont read the FAQ thats what we got u guys for to remind us that we r noobs lol :p
  13. tme

    tme New Member

    Messages:
    1
    Likes Received:
    0
    I had this problem and it wasn't because of my computer lacking in capability, I had to plug it up to the outlet, haha! I have a Lenovo T60p laptop and when I have it unplugged I set it to run on minimal settings. I hope that helps you.
    Last edited: Mar 4, 2009
  14. Zaertix

    Zaertix New Member

    Messages:
    28
    Likes Received:
    0
    Lol tme i had that same problem. :p I could never figure it out, then I set my laptop (dell xps m1530) to use high performance, and when I took it off battery, it was normal speed :D
  15. mudlord

    mudlord New Member

    Messages:
    1,761
    Likes Received:
    0
    Next time you annoy me, you get a infraction. Don't do it again.
Thread Status:
Not open for further replies.

Share This Page