PEC plugin not working w/ 1.7.0

Discussion in 'ePSXe Discussion' started by 0n1n3, Apr 18, 2010.

  1. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    Hello. I've been trying to see if I can get some of my old games to work.
    So I downloaded the emulator and popped in a game, but PEC is not showing up in the gpu plugins list. I have it installed and the gpupec.dll is in the plugins directory. But it's not showing up at all.
    I tried searching but there is no information. Does anyone have any help to offer?oO

    Thanks.
  2. NGEmu.com Advertisement

  3. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    the required runtime is not installed.
  4. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    Oh yeah, I should've checked the faq on the front page. Sorry about that.:innocent:


    I installed vb runtime 6 sp5 and it still doesn't show up. I don't think the dll is working right because in properties it doesn't have a version tab like all the other plugins do.




    nevermind, I can't get anything in this emu to work. I'm just going to stop and uninstall it. no big deal i guess.
    Last edited: Apr 18, 2010
  5. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    Update

    Other emulators work fine. I have no idea what the problem could have been. I guess we will never know.
  6. CheatMaster

    CheatMaster Active Member

    Messages:
    2,462
    Likes Received:
    1
    Make sure that you have gpupec.dll in your plugins directory,pec.ini(inside it you must have a line InterfacePath=where pec.exe is)and select "psx emulation cheater" as your video plugin

    PEC works fine here on 1.7.0,in fact I was making cheats now.
  7. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    I tried this again 2 months later and I'm still getting the same thing. I tried it with pcsx and it says it cannot read gpupec.dll. The whole point of using an emulator is to cheat so there is really no point in this. I kind of want to try to keep playing but this obviously isn't ever going to work.
  8. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    load the dll into dependency walker and post any missing dll's.
  9. CheatMaster

    CheatMaster Active Member

    Messages:
    2,462
    Likes Received:
    1
    I just tried on my virtual pc with one really old clean windows with nothing instilled to just copy epsxe(1.7),burutter.dll,zlib1.dll and the plugins folder with only gpupec.dll inside and "psx emulation cheater 2.5" was there on the GPU list.

    So no installation or special setting are needed to just see the "psx emulation cheater 2.5" in the GPU list.Are you sure that the file is not damaged or did you tried to run epsxe as administrator
  10. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    Hi. Thanks Squall. I used dependency walker and it is telling me this

    It has a yellow question mark next to MSJAVA.DLL
    and below that there is a red box next to MPR.DLL.

    I went to Java.com and checked my version of Java;
    Could my version of java be messed up?
    Nevermind, I tried to update my java and it didn't work.
    Another update, I replaced msjava.dll into windows/system from a trusted dll library, and it didn't work.


    [​IMG]
    Last edited: May 31, 2010
  11. CheatMaster

    CheatMaster Active Member

    Messages:
    2,462
    Likes Received:
    1
    Java has nothing to do with PEC.
    Did you tried running as administrator or/and disable DEP
  12. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    DEP really shouldnt be a problem these days, unless its software DEP.

    but yeah gpupec should be loading, i've installed it on countless systems, laptops, etc with never a problem even with dep enabled.
  13. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    It sounds like it could be a problem with my PC but I don't know what it could be. I am on XP.

    I searched something about that MPR.DLL possibly being infected but I did a virus scan with Avira Antivirus and it only found some false positives not related to MPR.DLL.

    Other than that ....... maybe Frame NET?
  14. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    nah, pec doesn't use .net at all. it was made well before .net even existed
  15. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    All of the other .DLL files in the plugin folder(s) have a version tab when you right click, but gpupec.dll does not have a version tab. It is missing a lot of information, almost like something with my computer is not reading the DLL properly.

    I do use this program called Advanced System Care to do a registry cleaning. Could it be possible that something like that deleted something important that my PC uses to read DLL files such as gpupec.dll? But if that were true, wouldn't I have trouble reading all DLL files? Because it just seems to be this one DLL that is giving me trouble.

    Does that narrow down any possibilities at all?
    Is there also any registry cleaning program that you would recommend to browse potential problems that could be causing this?
  16. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    gpupec never had a details tab iirc.
  17. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    [snip]


    AWwww..! It WAS DEP!!! :mad::mad::drool:
    lol I'm sorry Squall for wasting your time and I'm sorry CheatMaster for worrying you over nothing.

    DEP IS THE DEVIL!
    Ok. I'm going to go play some front mission 3 now.
    THANK YOU!!;)

    Squall and CheatMaster FTW. :thumb:
    Last edited: May 31, 2010
  18. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    what cpu do you have anyway?

    never had a dep on vista/7 with cpu's that support hardware nxbit
  19. 0n1n3

    0n1n3 New Member

    Messages:
    21
    Likes Received:
    0
    I have some crappy AMD. I swapped out my motherboard with an older motherboard when my motherboard went pop and stopped working. This motherboard isn't compatible with my intel CPU.
    I know I know I seriously need to upgrade my CPU.:???:
    Still using singlecore. :innocent:
  20. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    ah, i had dep issues on my AthlonXP as well using XP.

Share This Page