Quick FAQ for ePSXe under Linux, + USB joypad + 3D

Discussion in 'ePSXe Discussion' started by Adwin, Dec 21, 2004.

Thread Status:
Not open for further replies.
  1. Adwin

    Adwin New Member

    Messages:
    38
    Likes Received:
    0
    Universal FAQ for ePSXe under Linux, support for USB joypad + 3D acceleration

    1: First of all, I recommend Linux over Windows for obvious reasons: Stability, speed, etc... We won't delve into that matter as this is not the purpose of this FAQ.
    I actually assume, that you DO have a minimum knowledge of *NIX based machines.
    Everybody has some preferences but I actually would have 2 distros to recommend here.
    If you go for stability, opt for Debian.
    If you prefer speed and fast developping community, take over Gentoo Linux.
    Of course, I am not discriminating any other distributions, so feel free to adapt this FAQ to you own needs.

    DON'T FORGET TO LOGIN AS ROOT or SU, where needed.

    2: Kernel Parameters used to compile in order to make Joystick and 3D work:
    - Loadable Module support --> Enable all options there, opt for a non-modular kernel so you don't have to load at every startup the modules, but if you DO build a modular kernel, load the modules by adding its entry to /etc/modules.autoload.d/kernel-2.x (where x is your kernel series, i.e, kernel-2.4 --> If you have linux 2.4.xx or kernel 2.6 --> if you have linux 2.6.xx)
    I recommend using the 2.6.14.5 STABLE or the 2.6.15-rc7 standard (vanilla) kernel, if you want bleeding-edge. (At the time of writing)

    Now let's configure the necessary kernel options:
    CD into /usr/src/linux
    $make menuconfig

    - Processor type and features -->
    [*] MTRR
    - Device Drivers -->
    Input Device support -->
    <*> Joystick Interface
    <*> Gameport support
    <*> Enable your gameport interface here, eg: SB Live gameport
    [*] Joysticks
    <*> Your joystick

    Character devices -->
    <*> /dev/agpgart (You can enable/disable it as NVIDIA will provide its own AGPgart
    <*> Enable your AGP chipset here
    [ ] Direct Rendering Manager DISABLE THIS !!
    Graphics support -->
    [*] VESA VGA Graphics support
    USB Support -->
    <*> EHCI HCD support
    <*> OHCI HCD support
    <*> UHCI HCD support
    <*> USB Human Interface Device (full HID) support
    [*] HID input layer support
    [*] /dev/hiddev raw HID device support
    Block Devices -->
    <*> Loopback device support
    <*> Network block device support
    <*> RAM disk support
    [*] Initial RAM disk (initrd) support

    Networking support -->
    [*] Networking support
    Networking options -->
    <*> Unix domain sockets
    [*] Network device support


    To compile your kernel make:
    (for a 2.4 kernel) $ make dep && make clean bzImage modules modules_install
    (for a 2.6 kernel) $ make && make modules_install
    Copy over the kernel) $ cp arch/i386/boot/bzImage /boot; cp System.map /boot
    If you have an AMD64 system, that would be $ cp arch/x86_64/boot/bzImage /boot; cp System.map /boot


    3: Reboot your system.
    Before your system boots, plug in any Gameport / USB joysticks. (That is not a problem if you have hotplug enabled in your kernel and hotplug utils compiled)
    You can check if hotplug works by plugging in you USB pad for example and doing a:
    $dmesg | tail
    Your output should be similar to:

    #usb 2-1: new low speed USB device using uhci_hcd and address 2
    drivers/usb/input/hid-core.c: timeout initializing reports

    input: USB HID v1.00 Joystick [Logitech Inc. WingMan Gamepad] on usb-0000:00:10.0-1

    4: Download the latest Xorg package, for now being 6.9.0 (Or modularized 7.0)
    untar it and CD into the dir.
    Compile it using
    # make World
    make install
    REBOOT

    5:
    Install a window manager. I recommend fluxbox for the small size and well-proven stability.
    No KDE or Gnome, too much overhead, RAM / SWAP I/O.

    REBOOT
    login and now download from nvidia the kernel package, the latest being *1.0.8174*
    CD into your directory and:
    $ sh NVIDIA-Linux-x86-1.0-8174-pkg1.run

    OR

    $ sh NVIDIA-Linux-x86_64-1.0-8174-pkg2.run (if you have an AMD64, 64bit system)

    Build the kernel according to the README
    Do:
    #opengl-update nvidia (You should have compiled opengl-update prior to this step)

    6:
    LOAD the nvidia kernel module:
    $modprobe nvidia
    You can add the module to /etc/modules.autoload.d/kernel-2.* for autoloading at startup
    Start you window manager using:
    $ startfluxbox or startkde, whatever.
    You can create/edit ~/.xinitrc so that you add startfluxbox and
    $ startx, then it autostarts fluxbox

    7: TEST 3D in X:
    Open a terminal and
    # glxgears
    or
    # glxinfo | grep rendering
    you should see rendering:yes
    You should see 3 spinning gears

    8: Now download a binary release of ePSXe and download the latest plugins from ngemu.com or Pete Bernert's page for Audio/Video plugins.
    Use omnijoy or padjoy plugins for joystick support, not the built-in ePSXe pad support.
    Don't forget to switch on the ePSXe compatibility in the plugin config page.
    Now config your ePSXe to your liking and enjoy ePSXe on linux.

    Games I've tested.
    My machine config --> Hardware:
    - Dual AMD Opteron 242
    - 2*512Mb IBM RAM in Dual Channel mode
    - Palit NVidia GeForce FX5500
    - Logitech Wingman gamepad under gameport AND USB
    - VIA K8T800 chipset
    Software:
    - Gentoo Linux 1.6 built from stage 1
    - Kernel 2.6.13-rc2
    - Xorg 6.8.99.14 built from CVS sources.
    - Fluxbox Window Manager
    - Nvidia Kernel & Nvidia GLX 7664
    - ePSXe 1.60-r1
    - Latest ePSXe plugins from http://www.ngemu.com/psx/plugins.php?cat=1&os=linux

    Games I've tested that work 95% --> 100%
    - Gran Turismo NTSC/UC
    - Gran Turismo 2 PAL
    - Oddworld, Abe's Exodus NTSC/UC
    - Brave Fencer Musashi NTSC/UC
    - Metal Gear Solid PAL
    - Tony Hawks PAL
    - Final Fantasy 8 NTSC/UC
    - Final Fantasy 9 NTSC/UC
    - Fear Effect 2, Retro Helix NTSC/UC
    - Alone in the dark, the new Nightmare NTSC/UC
    - Tekken 3 NTSC/J
    - Tekken 3 PAL
    - Wip3out Special Edition PAL
    - Thrill Kill NTSC/UC
    - Twisted Metal 3 PAL
    - Twisted Metal 4 NTSC/UC
    - Earthworm Jim 2 NTSC/UC
    - Dino Crisis 2 NTSC/UC
    - Final Fantasy Tactics NTSC/UC
    - Kurushi 2 Final NTSC/UC
    - Mortal Kombat Mythologies : Subzero NTSC/UC
    - Cardinal Syn PAL
    - Dragon Ball GT PAL
    - Resident Evil 2 DUAL SHOCK Edition NTSC/UC
    - Resident Evil 3 NTSC/UC


    Enjoy!
    Please read up on any problems arising before asking for help.
    Last edited: Dec 27, 2005
  2. NGEmu.com Advertisement

  3. Crazed123

    Crazed123 New Member

    Messages:
    2
    Likes Received:
    0
    Just one problem... I can't run ISO's without a CDR plugin, the GUI seems to have no way to set one, and the Linux version of Mooby crashes all other configs whenever it's in the plugins directory.
  4. Adwin

    Adwin New Member

    Messages:
    38
    Likes Received:
    0
    Right after you start ePSXe, go to
    File --> Run ISO.
    ePSXe has built-in support for ISO files. That includes CloneCD images, BIN ect...
  5. ready2rumbelX

    ready2rumbelX InnarX

    Messages:
    2,756
    Likes Received:
    2
    Where's a manual for Linux n00bs when you need one? ;) But, seriously, I will try this out....

    Wonder if it will work with Fedora Core or Slackware....

    r2rX :D
  6. Seta-San

    Seta-San PCSX2ベータテスター

    Messages:
    1,448
    Likes Received:
    0
    you'll never have to deal with this kind of bullcrap in windows. the zero cost of owning linux doesn't make it a better alternative to windows
  7. I-Chan

    I-Chan Ex Contributors

    Messages:
    3,093
    Likes Received:
    0
    Funny, then why am i always answering emulation questions for windows users? Please post if you have something useful to add, baseless bashing is not. There have been enough Windows vs Linux threads, use them or create a new one.
  8. hushypushy

    hushypushy <font color=#FFFFFF><b>the only one you've ever SE Contributors

    Messages:
    21,979
    Likes Received:
    2
    fireblaster_lyz pointed this thread out, and it seems like a pretty good Linux guide to ePSXe, helping in an area that has little knowledge on these boards (linux emulation).
  9. Adwin

    Adwin New Member

    Messages:
    38
    Likes Received:
    0
    Please read up before criticizing people.
    OK, let me quote it for you:
    "1: First of all, I recommend Linux over Windows for obvious reasons: Stability, speed, etc..."
    I never used any zero-cost arguments.

    Anyway, linux distributions are more and more user-friendly, but the bulk of system administration just CAN'T be done just by clicking.
    This is the purpose of this FAQ anyway, to HELP people with it, so they can UNDERSTAND it and enjoy their emulation on this alternative platform, instead of just being tied to one choice, windows.

    I'm really sorry if I offend you, but from what I've read and understood (correct me if I'm wrong), you had little or none, or worse, bad experience with linux distributions. Please don't express you anger here.

    Anyway, I'd prefer die trying making my favorite emulator work under an alternative platform I like and see is better than another, than being tied to just one bad choice.

    I wish you all people who have supported me, and have found this FAQ useful, as well as POSITIVELY criticized me,

    A MERRY CHRISTMAS.
  10. hushypushy

    hushypushy <font color=#FFFFFF><b>the only one you've ever SE Contributors

    Messages:
    21,979
    Likes Received:
    2
    wow, that reply took a really long time :p
  11. Adwin

    Adwin New Member

    Messages:
    38
    Likes Received:
    0
    Well, I didn't really have the time to check out the forums since then.

    Merry Christmas and a Happy New year to all of you.
  12. hess

    hess New Member

    Messages:
    2
    Likes Received:
    0
    hhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii;) :) :emb: :p :D
  13. hushypushy

    hushypushy <font color=#FFFFFF><b>the only one you've ever SE Contributors

    Messages:
    21,979
    Likes Received:
    2
    uh huh. good job signing up and immediately making 2 retarded posts. maybe a temp ban will straighten you out. see you in a couple weeks.
  14. darth sephiroth

    darth sephiroth .!. (^.^) .!.

    Messages:
    2,017
    Likes Received:
    0
    and what do i do if my linux ubuntu 5.10 does not want to open the epsxe file? and also a friend of mine with the fedora core (unsure of the version) manages to at least open it, but when he tries to run the cdrom (unlike the lot of you who use ISO's, we got legitimate ps cd's) we get the notification that we ain't configured it yet, so whenever we try to configure graphics expse rudely shuts down like if it was a windows application without any error message before i even get to choose the plugin, the button for configure wizard is non-existant. help appreciated on BOTH cases.

    and i LOVE the espxe project!! (although my ffIX sprites shake a lot i love ultra high internal Y (or was it X) resolution :D
    allthough i have a sound problem i won't post it here :/
  15. darth sephiroth

    darth sephiroth .!. (^.^) .!.

    Messages:
    2,017
    Likes Received:
    0
    aaaahh ok i got some thngs activated in that synaptic package administration (or whatever), now i'm at my friends spot, crashes when i try to do plugins
    BUT
    when i created a short cut
    it didn't crash!
    but instead!!!
    it displayed "DISABLED" in the drop down menu!!!!!!!!
    HELP!!
  16. Metron

    Metron Episkopos Erisianus

    Messages:
    2
    Likes Received:
    0
    keyboard input?

    Ok, here's one... what if I don't own a game pad? Do I have to go out and buy one? :heh: The built-in keyboard support doesn't seem to work for me - I can use the arrows, but not the other buttons, doesn't matter what I bind to them. If I try to load one of the input plugins, it complains that I don't have a pad (well, I don't) - and anyway, the padjoy help claims it isn't necessary to use it for epsxe keyboard input, in fact it doesn't even support it.

    Configuration: Ubuntu Breezy, xorg 7.0; for gpu, I'm using soft X11 (the only one that works for me)

    EDIT: scratch that, I made it work. After booting the bios, I realised my keys were working after all, except for Start. Then I remapped it, and found that for some reason, I can't map the "l" key :???:

    The reason I thought no keys were working, is that the stupid game I was trying to run only accepts the Start button on the initial menu, whereas most actual PSX games I tried, will accept square too... :laugh:
    Last edited: Feb 20, 2006
  17. Metron

    Metron Episkopos Erisianus

    Messages:
    2
    Likes Received:
    0
    are you using the mooby CDR plugin? It makes epsxe crash for me on Ubuntu, due to a version mismatch with Xft. Anyway, it isn't necessary for epsxe - get rid of it, and the emulator may run.
  18. Mallow005

    Mallow005 New Member

    Messages:
    4
    Likes Received:
    0
    Unfortunately, I could not find a way to get FF9 to work for the life of me. I've used epsxe for FFTactics but FF9 just wouldn't work. The OpenGL2 plugin configuration is vastly different than the windows one, so the guides on the forums aren't much help.
  19. stilz

    stilz New Member

    Messages:
    608
    Likes Received:
    0
    Adwin, I personally don't use Linux, but I just want to say thank you for taking your time to write such informative post.
  20. canciman

    canciman New Member

    Messages:
    4
    Likes Received:
    0
    Hi!

    I have: PII 233 Klamath
    64 MB SDRAM
    Voodoo 3/2000 16 MB
    48x LG CDROM

    which runs ePSXe fairly good w/o sound; OK for me.

    Now,
    1. What HOWTO would you recommend me to enable Glide3 acceleration on Linux?
    2. What plugin to use? Lewpy doesn't seem to exist for Linux. :(
    3. Am I gonna enjoy the emulation? Meaning, are glide plugins avaible for linux as good as Lewpy's? Is it worth it? I'm sick of dual booting into WinME. Any speed up's to expect?
    4. What's better? Running ISOs directly in ePSXe or mounting them in Linux directly?

    I have Ubuntu Breezy on fluxbox 0.9. Soon plan to install Debian Sarge.

    TNX ;D
    Last edited: Jun 5, 2006
  21. DiKKy

    DiKKy New Member

    Messages:
    3
    Likes Received:
    0
    Okay i have an awkward problem, ePSXe runs great and all that, and a friend of mine had a psx-> usb port converter and i borrowed that + a few controllers and i just plugged it in and everything worked in epsxe without any hazzle at all. So my friend took the controllers back after a few days and i decided to order a thrustmaster usb gamepad, this does not work in epsxe.
    It appears in dmesg, and works great in a snes emulator i have.
    It also lets me map it within the Q's padjoy plugin, but i cant map any keys in the gamepad -> pad1 menu. Its like it doesnt recognize it. Trying the omnijoy plugin i cant get it to work at all using /dev/js0 or js1.
    Any thoughts on this?

    I use ubuntu 6.06 and everything else works great, 3d acceleration etc. Other usb devices and gamepads works as well, as i said.
Thread Status:
Not open for further replies.

Share This Page