ROM or Emu Problem?: Mega Man Battle Network Series

Discussion in 'Visualboy Advance Discussion' started by VelenX, May 15, 2012.

Thread Status:
Not open for further replies.
  1. VelenX

    VelenX New Member

    Messages:
    11
    Likes Received:
    0
    Okay, putting aside my previous problem with VBA OSX (I decided to use the Windows version of the original), I went ahead and played Mega Man Battle Network 3 Blue for the first time in a long while...then I found a problem that seems to be very common between the game's I have played from that series on VBA:

    For whatever reason, certain enemies who launch projectiles on screen, will inexplicably fail to launch them.

    The degree of this glitch/ bug/ error varies from game to game in the series, from being unable to launch unless the player is on the same row of panels, to not being able to launch if they are two rows down from the player, to pseudorandomly being unable to launch a projectile at all in any case whatsoever.

    This seems to be a problem with how VBA handles objects on screen (I can't be sure, however, I'm no programmer and couldn't decipher VBA's code if I tried), and this seems to happen to all enemies who launch projectiles high up on or off the screen in an arc, with a few exceptions.

    This happens with every enemy in the games that launches projectiles in an arc.

    Has anyone else experienced this on other GBA emulators, or knows if there are versions of these roms that don't contain the problem? It would be nice to know.
  2. NGEmu.com Advertisement

  3. SCHUMI_4EVER

    SCHUMI_4EVER Hackin 'n Slashin Staff Member Award Winner!

    Messages:
    28,455
    Likes Received:
    10
    I never noticed that when I played.
    That said you'll notice when you use the chip attacks that many of the projectiles and attacks have set ranges and rules and these likely aren't being satisfied under the conditions you describe. That and some enemies tend to be on the slow side so if you keep moving they'll never get to the point where they attack you especially if you keep moving in and out of range.
  4. VelenX

    VelenX New Member

    Messages:
    11
    Likes Received:
    0
    A full explanation of the problem and an additional one

    That's not the case with the Beetanks or Beetank-like enemies in the games. Let me give you examples:

    In BN1 and 2, the Beetank will move up and down, stop, and attack as normal, however, the Beetank will sometimes seem to "misfire" and not launch a projectile in it's usual arc at all, instead firing nothing. There are times when it fires that the bomb sprite can be seen on screen for a moment before disappearing completely. Again, this happens consistently, but not all the time, as it will sometimes fire off it's bomb successfully.

    In BN2 with the KillerPlant viruses. Any Killerplant will not be able to launch it's Treebombs onto the front column at all if it is in the top row of panels on the enemy's side, unless you happen to be on the same row when it does launch them. This has happened consistently as I have tested this myself.

    Then in BN3, the Beetle viruses exhibit similar behavior as the Beetanks, something I remember never happening, ever.

    I don't know about BN4 because I haven't played it consistently, but in BN5, the Beetanks make a return and behave exactly the same as I described as in BN2 and 1.

    -and in BN6, the only projectile launching virus I had the chance to encounter at the point I played to was the Puffy viruses. Unlike all the rest, these viruses would always successfully launch their attack...The problem is that it is invisible the entire time, meaning you cannot see the needles it launches at all.

    This problem with enemy projectiles that are launched in arcs has been consistent, so it makes me wonder if it may be a VBA issue rather than the ROMS, cause I highly doubt that every ripped ROM of these games could possibly end up having the exact same, similar flaw every time.

    I've tried downloading two different rips of the same ROM from two different sites (*snip* and *snip*), and they all seem to have the same problem.

    Surprisingly, the chips don't experience the same problems at all, which makes me wonder whether it may be an AI flaw caused by ripping the ROMs from the cartridges, or that VBA is not handling the AI correctly, causing the flaw.

    Another problem with a different game from another series that I noticed has to do with a problem with sprite flicker: Mario & Luigi: Superstar Saga.

    During cutscenes, the sprites on screen will consistently flicker occasionally without foreseeable cause. This also happens sometimes during battle.
    Last edited by a moderator: May 15, 2012
  5. SCHUMI_4EVER

    SCHUMI_4EVER Hackin 'n Slashin Staff Member Award Winner!

    Messages:
    28,455
    Likes Received:
    10
    I'm sorry but that was a bit too much information, since you listed ROMsites it shows illegal activity (whereas before you got the benefit of the doubt from don't ask don't tell) which breaks our Rules and therefore I can't give you any more support with those games and that's why your thread has been locked.

    That said I will leave you with a little extra. I never experienced any of that stuff and I didn't do anything special to either the game or the emulator so once again the problem comes from elsewhere. And even if it was some glitch in the emulator you'd still be out of luck since VBA is dead so there won't be any fixes for any existing glitches.
Thread Status:
Not open for further replies.

Share This Page