Saving in Platinum takes a long time, then fails

Discussion in 'DeSmuME Discussion' started by Yomoska, May 11, 2011.

  1. Yomoska

    Yomoska New Member

    Messages:
    2
    Likes Received:
    0
    For some reason every time I save in Platinum, it will sit there for a long time then eventually it just says save failed. I looked at the .dsv while saving and it goes from 513kb to 0, back to 513kb and keeps repeating until it says it failed. When I reset it says the save has been corrupt.

    Edit: Oh I forgot to say the save I use was converted from No$GBA and it will load up just fine but it refuses to save. I have to keep a backup because when I attempt to save it just corrupts.
    Last edited: May 11, 2011
  2. NGEmu.com Advertisement

  3. Phinja

    Phinja In Your Bedroom .^.^.

    Messages:
    21
    Likes Received:
    0
    sticky predicament.... i have that too... well the long save part, my saves work JUST fine, im not really sure why yours is actin up, if it was from No&GBa, Then i think i might know, but before i start blabing things out i will go check my theory, this could take a while so bear with me ok?
  4. Phinja

    Phinja In Your Bedroom .^.^.

    Messages:
    21
    Likes Received:
    0
    Ok, I'm Not Sure If This Will Help You, But i Hope It Does!

    Go Click The Options Button On Top. Then To tT Emulation Settings, And Go Down To The NDS Backup Tab. Click On Flash512bts And Click oOn OK. Then Click On Options Tab And Click Save Options, Then Reset The Cartridge. It Should Save From Then On Out.
  5. molh394

    molh394 New Member

    Messages:
    64
    Likes Received:
    0
    Oh man, your version of DeSmuME is outdated! What version are you using? The latest is v0.9.7 you know.

    @Yomoska: I will start with some standard instructions: Ensure you are using v0.9.7. Ensure you have Imported the No$gba save using File -> Import Backup Memory (instead of any other method of conversion I guess). Ensure that neither your ROM nor DeSmuME is in a zip file. Place all of them in a My Documents folder.

    Also go to Config -> Path Settings -> SaveRam. Ensure that folder is somewhere in My Documents, or at least somewhere on the harddisk that is not read-only/that desmume does not have the rights or permissions to save in.

    You might also like to see this: Faq - DeSmuME

Share This Page