Speed issues on the VisualBoy Advance

Discussion in 'Visualboy Advance Discussion' started by Prowlor, Jul 23, 2008.

  1. Prowlor

    Prowlor New Member

    Messages:
    1
    Likes Received:
    0
    I am using VisualBoy Advance and It is a great emulator, but I have been having trouble with the speed it sometimes runs games at. Every once in a while, usually when I switch the emulator between computers, it ends up running games at 200, 300, even sometimes up to 600% speed, and it makes it hard to play any of the games. Usually, after messing around with the frameskip options I can get it near a normal speed (usually pushing the throttle to 100%, making it run at about 120-150%) but I would really like being able to fix the speed issues.

    Anyone have any idea how I can make it play the games at normal speeds? sometimes it does run it at 100% like its supposed to, but usually it doesn't.
  2. NGEmu.com Advertisement

  3. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    Disable throttling.
    Enable Vsync
    Enable Audio Sync.

    Problem solved.
  4. zzz.sleeping

    zzz.sleeping New Member

    Messages:
    3
    Likes Received:
    0
    options/emulator/ speed up toggle!

    This speeds it up

    Also, go into sound and turn it off. This also speeds it up
  5. imlost

    imlost ಠ_ಠ

    Messages:
    2,363
    Likes Received:
    0
    TC wants to slow down the speed, so that the games run at a normal speed.
  6. Tom Barrister

    Tom Barrister New Member

    Messages:
    2
    Likes Received:
    0
    I was having a problem with the directional keys being sluggish and either not moving at all or moving two squares instead of one. Disabling throttling fixed it. Thanks for the help.
  7. kevr

    kevr New Member

    Messages:
    1
    Likes Received:
    0
    +Disable Throttling
    +Enable Vsync
    +Enable Synchronize in the Emulator tab

    -Enable Audio Sync has nothing to do with it.


    thanks for posting m8
  8. Squall-Leonhart

    Squall-Leonhart NGemu Award Winner Award Winner!

    Messages:
    23,270
    Likes Received:
    0
    Audio synching prevents sound crackling.
  9. s2em

    s2em New Member

    Messages:
    1
    Likes Received:
    0
    hi there!
    I have the opposite problem:
    I used to play at normal speed, and then speed up with the space key when I needed, it was greatly useful.

    I'm using 1.8.0

    in these last two days the emu started to have some problem,
    I start it and play for some time (about 10 minutes), and then it suddenly "speeds up" to 130% when I press the speed-up key, instead of the normal 200\300%.

    I have the same problem with differents games/versions of vba.

    EDIT:
    i exported battery file and started playin' on version 1.7, as usually the game starts with a certain amount of turbo speed (500% if i hit start just after starting the emu) and slows down after some minute, and i only have to restart to have that max speed again.
    Last edited: Jun 15, 2010
  10. Yurda

    Yurda New Member

    Messages:
    1
    Likes Received:
    0
    As for me: I'm not sure it's a speed issue, but the emulator acts as if I'd hit the control keys several times.

    The speed is normal (100%) and nothing changes when the issue occurs, just that if I move, the emulator acts as if I've moved twice to thrice what i want, including other keys such as A, B or Y and Z.

    I tried different solution, including those above, even changing version (1.7 or 1.8), I even tried to slow the keyboard speed repetetion through OS setup, but the key problem still occur, making my game impossible to play.

    Any idea?

    Thanks a lot.
  11. Goofy Garcon

    Goofy Garcon New Member

    Messages:
    1
    Likes Received:
    0
    I have a problem with my VBA except its a little different. I'm trying to control the throttle in that I want to limit how fast it can go. When I use it it goes up to about 1000% but I'd rather limit it to a couple hundred. How can I do that?
  12. ImAnApple

    ImAnApple New Member

    Messages:
    1
    Likes Received:
    0
    Emulator Issues With Speed

    Quite some time ago i just launched a game and the speed immediately jumped up to 200-1000% speed, and i turned on VSync and all that fancy business, but it still runs at 100-200% speed, how do i get it to run normally? (PS sync, vsync are enabled and throttle is disabled.)
  13. SCHUMI_4EVER

    SCHUMI_4EVER Hackin 'n Slashin Staff Member Award Winner!

    Messages:
    28,455
    Likes Received:
    10
    You mention nothing about enabling audio sync

Share This Page